Situação
Ao enviar o evento S-2299 (Desligamento), o sistema retorna a seguinte inconsistência:
CÓDIGO 191: Não é permitido o desligamento do trabalhador. Ações Sugeridas: - Verificar se o trabalhador encontra-se ativo - Verificar se o motivo do desligamento do trabalhador é compatível com o desligamento sem retorno do afastamento ou sem o fim da cessão/exercício em outro órgão.
Causa
Essa inconsistência pode ocorrer em um dos seguintes casos:
- A situação do colaborador está diferente de Ativo no eSocial;
- A data de retorno do afastamento é posterior à data de desligamento;
- As datas de retorno do afastamento e de desligamento são iguais.
Solução 1
Situação do colaborador diferente de Ativo no eSocial
- No Portal do eSocial, acesse o menu: Empregado > Gestão de Empregados.
- 
Informe o CPF do colaborador.
- Verifique sua Situação atual.
- Se o empregado constar como Afastado ou Em Férias, verifique qual afastamento está cadastrado sem Data de Fim.
- Informe a Data Fim do Afastamento/Férias no eSocial.
- Reenvie o evento S-2299 do colaborador.
- Aguarde o retorno como Aceito no Gerenciador de Eventos.
Solução 2
Data de retorno do afastamento posterior ao desligamento
- No Portal do eSocial, acesse o menu: Empregado > Gestão de Empregados.
- Informe o CPF do colaborador.
- Verifique, em Afastamento Temporário, a Data de Retorno do último afastamento.
- Caso a Data de Retorno seja posterior ao desligamento, exclua a rescisão e recadastre com a data correta de desligamento.
- Se a Data de Retorno estiver incorreta no eSocial, ajuste a informação diretamente no Portal.
Solução 3
Datas de retorno do afastamento e desligamento iguais
Essa coincidência não é permitida pelo eSocial. Para corrigir o erro, é necessário:
- Registrar o desligamento um dia após a data final do afastamento; ou
- Ajustar a data de retorno do afastamento para um dia antes da demissão.