Situação
Ao tentar efetivar uma rescisão de contrato, o sistema exibe a seguinte mensagem de erro/atenção:
Não foi possível efetivar a folha de rescisão para o contrato X, pois existem históricos para o contrato com data maior a XX/XX/XXXX.
Causa
Essa mensagem ocorre porque existe um histórico no contrato com data posterior à data de desligamento informada na rescisão.
Solução
1. No módulo de Folha de pagamento, acesse o menu: Rescisões > Registro de Rescisões.
1.1 Procure a rescisão em questão e dê um duplo clique sobre ela.
1.2 Verifique a Data do Desligamento informada no cálculo.
2. No módulo de Cadastros, acesse o menu: Pessoais e Contratuais > Contratos.
2.1 Localize o contrato do funcionário que será rescindido.
2.2 Na aba HISTÓRICOS, verifique a DATA DO HISTÓRICO do último registro.
2.3 Se essa data for posterior à data de desligamento, será necessário excluir o histórico.
- Selecione o registro e clique em EXCLUIR.
➡️ Importante! Se houver recibo calculado na competência do histórico, será necessário excluí-lo primeiro, caso contrário, não será possível excluir o histórico do contrato.