Situação:
Ao calcular uma rescisão, o sistema gera o seguinte Erro: System.Exception: Não há histórico registrado para o horário X no período de XX/XX/XXXX a XX/XX/XXXX
Causa:
A situação pode ocorrer devido à ausência de histórico referente ao período de admissão do colaborador, o que pode impactar a composição das informações utilizadas pelo sistema.
Solução:
Acesse o menu: Pessoais e Contratuais > Tabelas Contratuais > Horário, e localize o horário indicado na mensagem de erro.
Consulte o MÊS/ANO DO HISTÓRICO.
Importante! O MÊS/ANO DO HISTÓRICO deve ser igual ou anterior a admissão do contrato.Clique em NOVO A PARTIR DE.
Crie um Histórico com a Data da Admissão do contrato.

- Clique em Salvar.
- Faça o cálculo da Rescisão novamente.